
Outpost
Packet Message Manager

Version 2.0.4

Overview
Mountain View Amateur 
Radio Emergency Service

25 March 2006



Why are we here?
... and, why are we talking about packet?

Purpose
• City… provides services; promotes the common good
• EMS… ▪ Prepares for disasters

▪ responds to minimize loss of life and property
▪ speeds the recovery

Needs
• EMS… ▪ needs information… what’s going on out there?

▪ work with recovery partners and service providers

Capabilities
• What we bring…

▪ Volunteerism!… An interest to help out
▪ Communications 
▪ Structure
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Why are we here?
... and, why are we talking about packet?
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Capabilities… amateur radio communications
• Frequency agility
• Different modes… voice, data, video
• Bandwidth
• Independence from commercial services

Simple Messages Complex Messages 

Voice 

Short messages

Immediate 

Radio

Short learning curve 

Packet

Lists, instructions, details

Store & forward; mail drop

Radio + TNC+ PC + SW + BBS

Many commands

Mode

Messages

Delivery

Equipment

Complexity



Why are we here?
... and, why are we talking about packet?

Mapping Capabilities to Needs
• City EOC… PSAs, message handling with field sites, etc.

• County Emergency Medical Services System, Public Health Department 
Emergency Operations Center (DOC)… Casualty Collection Points, 
Ambulance Allocation, Hospitals, Surgicare Clinics

• Santa Clara County EOC… EOC-to-EOC message handling, 
RIMS backup

CAPABILITIES help fulfill NEEDS, that support PURPOSE

Is Packet a capability that could address other needs?
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Overview

What is Outpost?
• A Windows-based packet messaging client
• Supports ARES, RACES, and other amateur radio emergency response

teams and their need to pass digital traffic
• Helps automate the packet message handling environment
• Manages all message handling between you and your BBS
• Lets you read, delete, create, reply to, or forward messages back to the BBS
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Overview

Why use Outpost?
• Leverages the existing packet hardware, network, and BBS infrastructure

• Compatible with many existing BBSs and TNC PBBSs
• Uses your existing TNC and packet radio equipment
• Only a packet client (end-user) change is required

• Hides the complexity of the packet operating environment
• Similar look and feel to contemporary email programs
• Shorter learning curve for packet operations
• Allows users to… “focus on the message, not the medium”

• Implements most local emergency management policies for digital 
communications

• Still under active development based on user requests and on-going 
alignment with the Outpost mission.
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Overview

General Outpost Features
• Message Management

• Multiple message folders
• Supports the three primary message types:  Private, NTS, and Bulletins
• Text Formatting in a free-form message window
• NTS Message Maker with automated ARL message support
• On-line report builder using report templates
• Supports Urgent message, Delivery and Read Receipts

• Send/Receive Session Management
• Supports Serial, AGWPE, and Telnet interfacing to a BBS
• Automatically controls the sequence for initializing the selected interface, connecting to, 

and sending messages to and retrieving messages from the BBS

• Configurations and Setups
• BBS, TNC, and Interfaces – manages a list of BBSs & Interfaces
• Message Retrieval – choose the message types to be retrieved
• Send/Receive automation – 3 ways for automatically initiating BBS sessions
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Overview

Outpost History
• Commenced Development… November 2002 
• v0.95; First Beta Release… May 2003
• v1.0;  First Release… October 2003
• v1.1; enhanced look and feel… March 2004
• v1.2; on-line reports, MSYS support… May 2004
• v1.3; collaborative messaging… December 2004
• v2.0; AGWPE and telnet support… June 2005
• v2.0.4; NTS extensions, other enhancements… February 2006
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Topics

• Features
• Setups
• Tools and Controls
• Creating Messages
• A Typical Session
• Limitations and Constraints
• Questions
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Features

Message management
• Familiar email-app look and feel
• Separate folders for message 

storage
• Clearer message identification 

(unread=BOLD, urgent=Red)
• Follows a formal message 

workflow
• Manage BBS and interface 

setups
• Additional settings to control 

how Outpost behaves
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Features

Message viewing
• Supports viewing, printing, 

deleting or saving a 
message to a local file

• Reply and Forward 
message formatting
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Features

Message creation
• Supports Private, Bulletin, 

and NTS message types
• Message formatting before 

sending
• Set messages to Urgent
• Request delivery or read 

receipts
• Different ways for 

originating messages
• NTS Message Maker
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Setups

Application setups
• TNCs: create, update, or delete

•Configure Serial Comm Ports that 
are associated with each TNC

• BBSs: create, update, or delete
• Change the Station Identifier 

(the call sign assigned to the TNC)

13 Outpost Packet Message Manager 2.0.4



Setups

Application setups
• TNC Interface setup

•TNC Prompts
•TNC Commands
•Comm Ports

• AGWPE
• Telnet
Notes...
• Create, update, or delete interfaces.
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Setups - TNC

Application setups
• TNC Interface setup

•TNC Prompts
•TNC Commands
•Comm Ports

• AGWPE
• Telnet
Notes...
• Outpost sends TNC commands to 

the
TNC as part of the TNC 
initialization.

• Supports Hardware Flow Control. 
• Confirmed operational with 

USB-to-Serial port adapters.



Setups - AGWPE
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Application setups
• TNC Interface setup

•TNC Prompts
•TNC Commands
•Comm Ports

• AGWPE
• Telnet
Notes...
• Implements the AGWPE TCP/IP API 

specification.
• Supports AGWPE v2000.20 or 

higher.



Setups - telnet
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Application setups
• TNC Interface setup

•TNC Prompts
•TNC Commands
•Comm Ports

• AGWPE
• Telnet
Notes...
• Requires access to a LAN or 

internet, depending on where the 
BBS is.



Setups - BBS  

Application setups
• BBSs

•BBS Prompts
•BBS Commands

Notes...
• Defaults are the most common 

BBS commands.
• Need to be careful with BBS 

prompt uniqueness.

18 Outpost Packet Message Manager 2.0.4



Setups - BBS 
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Application setups
• BBSs

•BBS Prompts
•BBS Commands

Notes...
• BBS Prompts “Help>” and “Help >”

are not the same! 
• Need to be careful with BBS prompt uniqueness (like MSYS’s “>” prompt).
• When in doubt, manually connect to a BBS, and copy the BBS prompt as 

is… the more of the prompt there is, the better (less unique).
• Secondary Tactical Call Logon available (such as the modified AA4RE 

BBS).



Setups - BBS 

Application setups
• BBSs

•BBS Prompts
•BBS Commands

Notes...
• Common commands that Outpost

needs to interact with the BBS.
• Outpost sends these commands to the BBS as part of the send/receive 

session. 

20 Outpost Packet Message Manager 2.0.4



Tools and Controls

Types of controls
• Controls the flow of each Send/Receive 

Session 
• Sets how messages are created and

handled
• Set various data fields to automatically 

populate on-line reports, messages, 
other areas

• Set up default Directory Names
• Various Log Settings
• Controls to re-size message listing

column widths
• Separate Interactive Packet Windows for Serial, AGWPE, and Telnet 

where the user can manually interact with the TNC (Serial only) or BBS
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Tools and Controls 

Send/Receive Settings
• Selects different ways to 

schedule message 
send/retrieve sessions

• Select which message types 
are to be retrieved

• Once a message is received, 
select what to do with it
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Tools and Controls 
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Message Settings
• Define default settings for new 

messages, includes
• Default destinations
• Auto message numbering

• Handling replies and forwards 
• Set up defaults for requesting 

message receipts
• Setting for permanently 

deleting messages 



Tools and Controls 

Report Settings
• Message number automatically 

increments and populates…
• the Subject Line
• NTS Messages
• On-line reports

• Standard report variables 
automatically replace <tags> in 
On-line Reports (described 
later)

• Three flexible fields are user-
defined and automatically 
replace <tags> in On-line 
Reports
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Tools and Controls 

Directory Settings
• Used for optional organization 

of application files…
• Archive directory is used for 

message archive export and 
import files (*.oaf)

• Reports directory is checked 
for any On-line Reports (*.txt)

• Log directory is home for all 
Outpost logs (*.txt)

• On first time startup after 
installation, the directories 
listed here are created

• User defined to any existing or 
new directory on the PC
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Tools and Controls 
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Other Controls
• General Settings… 

• Show station ID form on startup
• TNC Session counter displays in

session logs; increments with each
Send/Receive Session

• Bulk delete of the Deleted Msgs 
Folder

• Display controls
• Resets column widths to their

default settings
• Packs column widths for optimal 

viewing
• Resets the form if it gets stuck in a 

“minimized” state



Tools and Controls 
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Interactive Packet Window
• Windows to manually interact 

with the TNC (serial only) and 
BBS by

• AGWPE
• Telnet
• Serial

• Logging controls
• Cut-and-paste clipboard support 

into and out of the IPW window
• use the Edit control on the 

menu
• cntl-c gets the TNC’s attention

• Directly create an Outpost 
message from highlighted IPW 
text



Messages

•Creating Messages
• Direct Entry
• NTS Message Maker
• On-line Report Builder
• Cut-and-paste from other apps
• Import Text from a file

•Special Message Handling
• Bulletins
• NTS
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Creating Messages

Direct entry
• Allows cursor placement 

within the text field
• Supports TAB characters 

(cntl-tab) thereby reducing 
character count

• Allows text files to be directly 
imported into the message 
form
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Creating Messages

NTS Message Maker
• Step 1: Forms-based with field 

validity checking
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Creating Messages

NTS Message Maker
• Step 1: Forms-based with field 

validity checking
• Step 2: Press Check; 

reformats  the message per 
the agreed NTS Packet 
message standard
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Creating Messages

NTS Message Maker
• Step 1: Forms-based with 

field validity checking
• Step 2: Press Check; 

reformats  the message per 
the agreed NTS Packet 
message standard

• Step 3: Saves the message to 
a message window; message 
type is NTS.  Press Send 
when ready.
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Creating
Messages
NTS Message Maker
• For ARL Messages… 

• Select the message Type… 
Routine or Emergency

• Select the message
• Provide any additional 

information
• Send the message as usual
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Creating Messages
Tag Description

= Prompt
/ comment Place a comment in the report

<D>, <date1> mm/dd/yy (5/21/04). 
<date2> dd-mmm-yyyy (21-May-2004)
<T>, <time> hh:mm (22:45)
<M>, <msg#> Message Number; from Report Settings
<C>, <call> Call, as entered at the Station ID form
<name> Name, as entered at the Station ID form
<bbs> BBS name; current BBS
<subj>text Places “text” on subject line
<org> Organization; from Report Settings
<city> City name; from Report Settings
<county> County name; from Report Settings
<state> State name, 2 char; from Report Settings
<province> Province name, 2 char; instead of state
<tacloc> Tactical Location; from Report Settings
<tacid> Tactical ID, 3 char; from Report Settings
<text1, 2, 3> User defined text; from Report Settings

On-line Report Builder
• Step 1: Set up the Report 

Settings (described 
previously)

• Step 2: Understand the list of 
Report <tags>
NOTE: there are some report 
variables that have to methods 
for representing them
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Creating Messages

On-line Report Builder
• Step 1: Set up the Report 

Settings (Tools > Report 
Settings)

• Step 2: Collect the list of 
Report tags, most in the 
format “<tag>”

• Step 3: Develop the report 
template, save as a .txt file.
NOTE: see the use of 
comments (/), <tags>, and 
prompts (=) 
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Creating Messages
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On-line Report Builder
• Step 1: Set up the Report Settings

(Tools > Report Settings)
• Step 2: Collect the list of Report 

tags, most in the format “<tag>”
• Step 3: Develop the report

template, save as a .txt file.  
• Step 4: From a new message

form, “File > Open a Report” and
choose a report template.
NOTE: Subject line is updated,
<tags> are replaced, and cursor is
positioned at the first prompt. 

• Press cntl-Tab or left-mouse to progress to the next prompt.
• Press “File > Clear Remaining Prompts” for any unfilled prompts
• Press Send when done.
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Creating
Messages
Cut-and-Paste from

other apps
• From Excel, highlight the 

fields to be copied, then 
paste into an Outpost 
message.

• At the receiving station, 
highlight and copy the 
message, then paste back 
into Excel.

• Tabs are preserved so the 
message can be pasted 
back into another 
spreadsheet.



Creating Messages
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Import text from a file
• Open a new message
• File > Open a file
• Select the text file, press 

OK
• Full in the Destination and 

Subject.
• Press Send when done.



Special Message Handling

Bulletins
• To delete a bulletin off of the 

BBS
that you originated…
• Retrieve the bulletin from the BBS
• Open the message
• Press Expire
• On the next send/receive session, 
the bulletin will be deleted off of 
the BBS.

Notes
• You can on delete bulletins that 

you create
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Special Message Handling

NTS Messages
• Retrieved NTS messages are 

not automatically deleted off of 
the BBS.  To accept a message 
for servicing… 
• Retrieve the NTS message from
the BBS

• Open the message
• Press Accept
• On the next send/receive session, 
the NTS message will be deleted 
off of the BBS.

Notes
• If you change your mind and do not plan to service the NTS 

message, it is common courtesy to post it back up on the BBS
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Exit the BBS,
Shut down the Interface

Initialize the Interface

Connect to the BBS

Send all messages
from Out Tray

If Private is set
• Retrieve List, Read, and 

Delete each message

If NTS is set,
• Retrieve List and Read 

each message

If Bulletins is set,
• Retrieve List, if don’t have 

it, read each message

Send any message
delivery, read receipts

Process Bull, NTS deletes

A Typical Session
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Exit the BBS,
Shut down the Interface

Initialize the Interface

Connect to the BBS

Send all messages
from Out Tray

If Private is set
• Retrieve List, Read, and 

Delete each message

If NTS is set,
• Retrieve List and Read 

each message

If Bulletins is set,
• Retrieve List, if don’t have 

it, read each message

Send any message
delivery, read receipts

Process Bull, NTS deletes

A Typical Session

• Influenced by…
• Send/Receive Settings

• Send Messages
• Only sent from the Out Tray to this BBS
• Messages must be “Sent” not “Saved”
• Moved to Sent Folder when sent

• Retrieve Messages
• Depends on the Retrieve settings; if none 

are selected, none are retrieved
• Depends on the “Keep on BBS” setting
• Bulletins are never deleted
• New messages are stored in the In Tray

• Send Receipts
• Any pending Delivery and Read Receipts 

are sent back to the requester



Considerations, Limitations and 
Constraints
What Outpost does not do
• No support for any bulletin board forwarding protocol
• No support for common mail protocols (POP3, SMTP, etc.)

Things to avoid
• Sending bulletins to a named person (instead of a group Identifier such as 

ALLEOC, etc.) will cause repeated retrievals by that person
• Embedding the BBS prompt string in a message (fails to ensure the 

uniqueness of the BBS prompt) will cause erroneous results
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What’s Next 

•Enhanced Packet Network Support 
• KA-Node, NET/ROM routing

•Generic Tactical Calls

•Attachments

•Winlink client support
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For more information

Send inquiries to…
Jim Oberhofer, kn6pe@arrl.net

Visit the Outpost website…
http://www.CupertinoARES.org/projects/outpost

Or, Google… outpost packet
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Questions?
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