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Overview
Outpost Packet Message Manager

What is Outpost?
• A Windows-based packet messaging client
• Supports ARES, RACES, and other amateur radio emergency response

teams and their need to pass digital traffic
• Helps automate the packet message handling environment
• Manages all message-handling between you and your BBS
• Lets you read, delete, create, reply to, or forward messages back to the BBS
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Overview
Outpost Packet Message Manager

Why use Outpost?
• Leverages the existing packet hardware, network, and BBS infrastructure

• Compatible with many existing BBSs and TNC PBBSs
• Uses your existing TNC and packet radio equipment
• Only a packet client (end-user) change is required

• Hides the complexity of the packet operating environment
• Similar look and feel to contemporary email programs
• Shorter learning curve for packet operations
• Allows users to… “focus on the message, not the medium”

• Implements most local emergency management policies for digital 
communications

• Still under active development based on user requests and on-going 
alignment with the Outpost mission.



5 Outpost Packet Message Manager 2.2.0

Overview
Outpost Packet Message Manager

General Outpost Features
• Message Management

• Multiple message folders
• Supports the three primary message types:  Private, NTS, and Bulletins
• Text Formatting in a free-form message window
• NTS Message Maker with automated ARL message support
• On-line report builder using report templates
• Supports Urgent message, Delivery and Read Receipts

• Send/Receive Session Management
• Supports Serial, AGWPE, and Telnet interfacing with over 20 of PBBS and BBSs
• Automatically controls the sequence for initializing the selected interface, 

connecting to, 
and sending messages to and retrieving messages from the BBS
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Overview
Outpost Packet Message Manager

General Outpost Features
• Configurations and Setups

• BBS, TNC, and Interfaces – manages a list of BBSs & Interfaces
• Message Retrieval – choose the message types ti be retrieved
• Send/Receive automation – 3 ways for automatically initiating BBS sessions
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Overview
Outpost Packet Message Manager

Outpost History
• Commenced Development… November 2002 
• v0.95; First Beta Release… May 2003
• v1.0;  First Release… October 2003
• v1.1; enhanced look and feel… March 2004
• v1.2; on-line reports, MSYS support… May 2004
• v1.3; collaborative messaging… December 2004
• v2.0; AGWPE and telnet support… June 2005
• v2.0.4; NTS extensions, other enhancements… February 2006
• v2.1: Tactical Calls; KA-, Netrom Node support October 2006
• v2.2: Winlink/telpac, other BBS support… April 2007
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Features
Outpost Packet Message Manager

Message management
• Familiar email-app look and feel
• Separate folders for message 

storage
• Clear message identification 

(unread=BOLD, urgent=Red)
• Follows a formal message workflow
• Manage BBS and interface setups
• Additional settings to control how 

Outpost behaves
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Features
Outpost Packet Message Manager

Message viewing
• Supports viewing, printing, 

deleting or saving a message 
to a local file

• Reply and Forward message 
formatting
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Features
Outpost Packet Message Manager

Message creation
• Supports Private, Bulletin, 

and NTS message types
• Message formatting before 

sending
• Set messages to Urgent
• Request delivery or read 

receipts
• Different ways for originating 

messages
• NTS Message Maker
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Setups
Outpost Packet Message Manager

Application setups
• TNCs: create, update, or delete

•Configure Serial Comm Ports that 
are associated with each TNC

• BBSs: create, update, or delete
• Change the Station Identifier 

(the call sign assigned to the TNC)
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Setups
Outpost Packet Message Manager

Application setups
• TNC Interface setup

•TNC Prompts
•TNC Commands
•Comm Ports

• AGWPE
• Telnet
Notes...
• Create, update, or delete interfaces.
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Setups – Serial TNC
Outpost Packet Message Manager

Application setups
• TNC Interface setup

•TNC Prompts
•TNC Commands
•Comm Ports

• AGWPE
• Telnet
Notes...
• Outpost sends TNC commands to 

the TNC as part of the TNC 
initialization.

• Supports Hardware Flow Control. 
• Confirmed operational with 

USB-to-Serial port adapters.
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Setups – AGWPE
Outpost Packet Message Manager

Application setups
• TNC Interface setup

•TNC Prompts
•TNC Commands
•Comm Ports

• AGWPE
• Telnet
Notes...
• Implements the AGWPE TCP/IP API 

specification.
• Supports AGWPE v2000.20 or 

higher.
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Setups – telnet
Outpost Packet Message Manager

Application setups
• TNC Interface setup

•TNC Prompts
•TNC Commands
•Comm Ports

• AGWPE
• Telnet
Notes...
• Requires access to a LAN or the 

internet, depending on where the 
BBS is.
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Setups – BBS  
Outpost Packet Message Manager

Application setups
• BBSs

•BBS Prompts
•BBS Commands
•BBS Path

Notes...
• Auto-identifies BBSs and 

determines the BBS Prompts
• Special handling for non-

identifying BBSs
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Setups – BBS 
Outpost Packet Message Manager

Application setups
• BBSs

•BBS Prompts
•BBS Commands
•BBS Path

Notes...
• This form is disabled if you checked:

“Let Outpost determine the BBS and setup the prompts”
• If you checked: “User defines the BBS Prompts”, only the command 

prompt is typically used;   all other fields default to the Command prompt.
• Remember that “Help>” and “Help >” are not the same! 
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Setups – BBS 
Outpost Packet Message Manager

Application setups
• BBSs

•BBS Prompts
•BBS Commands
•BBS Path

Notes...
• Common commands that Outpost

needs to interact with the BBS.
• Outpost sends these commands to the BBS as part of the send/receive 

session. 
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Setups – BBS 
Outpost Packet Message Manager

Application setups
• BBSs

•BBS Prompts
•BBS Commands
•BBS Path

Notes...
• Direct:  from your station to the BBS
• Digipeat: one or more digipeater stations between you and the BBS
• KA-Node/Netrom:  one or more nodes between you and the BBS
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Setups – BBS 
Outpost Packet Message Manager

Setting up nodes
Do not start without…
1. Understanding the path between 

you and the BBS
2. The information needed to define

each node…

3. When in doubt: see the Application Note titled Setting up KA-Node/Netrom Network 
Access on the Outpost website for a more detailed walk-through of this topic. 

The string returned by the current node to tell Outpost that the next connect was not 
successful.

Unsuccessful Connect 
Message

The port number to be taken out of this node to the next node.  Some nodes have 
multiple radio ports typically set up on different bands.  For single channel nodes, leave 
this value as 0.

Port Number

The string that is returned by the node indicating that the connection was successfulSuccessful Connect 
Message

The actual connect name of a node in the node path, such as K6FB-7 or W6TDM-7.Node Name
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Setups – BBS
Current list of supported BBSs

Notes…
• The above list is effective as of 26-April-2007.
• See the http://www.outpostpm.org/bbs/ for...

•Updates and the latest list of supported BBSs
•Instructions on how to get your BBS supported

Support pending
(26-Apr-2007)

BBSs (Software-based)PBBSs (Firmware-based, 
resides in TNCs)

AA4RE
F6FBB
MSYS
N0ARY
DXNET
Telpac/Winlink
W0RLI

KPC3 5.1
MFJ-1274
OpenBCM
JNOS
TNOS

KPC3, KPC3+
KPC9612
KAM, KAM-XL, KAM-98 
KAM Plus
Kantronics’ Data Engine
PK-88, PK-232, PK-88
DSP-232 
MFJ-1270x
MFJ-1278
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Tools and Controls
Outpost Packet Message Manager

Types of controls
• Controls the flow of each Send/Receive 

Session 
• Sets how messages are created and

handled
• Set various data fields to automatically 

populate on-line reports, messages, 
other areas

• Set up default Directory Names
• Various Log Settings
• Controls to re-size message listing

column widths
• Separate Interactive Packet Windows for Serial, AGWPE, and Telnet where 

the user can manually interact with the TNC (Serial only) or BBS
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Tools and Controls 
Outpost Packet Message Manager

Send/Receive Settings
• Selects different ways to automate the 

message send/retrieve sessions
• Select which message types are to be 

retrieved
• Once a message is received, select what to 

do with it
• Additional controls (Other tab)

manage printing received and 
sent messages
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Tools and Controls 
Outpost Packet Message Manager

Message Settings
• Define default settings for new 

messages, includes
• Default destinations
• Auto message numbering
• Message Signature

• Handling replies and forwards 
• Set up defaults for requesting 

message receipts
• Setting for permanently deleting 

messages 
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Tools and Controls 
Outpost Packet Message Manager

Report Settings
• Message number automatically 

increments and populates…
• Subject Line
• NTS Messages
• On-line reports

• Standard report variables automatically 
replace <tags> in On-line Reports 
(described later)

• Note where tags are used…

XText Variable #2, 3
XTactical TX Text

XXTactical ID
XTactical Location

XXState/Prov
XCounty

XXCity
XOrganization

XXXNext Message Number

Message
Subject 

Line

NTS
Message 

Maker

On-Line
Reports

Field
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Tools and Controls 
Outpost Packet Message Manager

Directory Settings
• Used for optional organization of 

application files…
• Archive directory is used for 

message archive export and 
import files (*.oaf)

• Reports directory is checked for 
any On-line Reports (*.txt)

• Log directory is home for all 
Outpost logs (*.txt)

• On first time startup after 
installation, the directories listed 
here are created

• User defined to any existing or 
new directory on the PC
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Tools and Controls 
Outpost Packet Message Manager

Other Controls
• General Settings… 

• Show station ID form on startup
• TNC Session counter displays in

session logs; increments with each
Send/Receive Session

• Bulk delete of the Deleted Msgs Folder
• Display controls

• Resets column widths to their
default settings

• Packs column widths for optimal viewing
• Resets the form if it gets stuck in a “minimized” 

state
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Tools and Controls 
Outpost Packet Message Manager

Interactive Packet Window
• Programs to manually interact with 

the TNC (serial only) and BBS by
• AGWPE
• Telnet
• Serial

• Logging controls
• Cut-and-paste clipboard support 

into and out of the IPW window
• use the Edit control on the menu
• cntl-c gets the TNC’s attention

• Directly create an Outpost message 
from highlighted IPW text
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Messages
Outpost Packet Message Manager

•Creating Messages
• Direct Entry
• NTS Message Maker
• On-line Report Builder
• Cut-and-paste from other apps
• Import Text from a file

•Special Message Handling
• Bulletins
• NTS
• Telpac/Winlink messages
• Tactical Calls
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Creating Messages
Outpost Packet Message Manager

1. Direct entry
• Allows cursor placement within 

the text field
• Supports TAB characters 

(cntl-tab) thereby reducing 
character count

• Allows text files to be directly 
imported into the message form
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Creating Messages
Outpost Packet Message Manager

2. NTS Message Maker
• Step 1: Forms-based with field 

validity checking
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Creating Messages
Outpost Packet Message Manager

2. NTS Message Maker
• Step 1: Forms-based with field 

validity checking
• Step 2: Press Check; reformats  

the message per the NTS Packet 
message standard
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Creating Messages
Outpost Packet Message Manager

2. NTS Message Maker
• Step 1: Forms-based with field 

validity checking
• Step 2: Press Check; reformats  

the message per the agreed NTS 
Packet message standard

• Step 3: Saves the message to a 
message window; message type 
is NTS.  Press Send when ready.
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Creating Messages
Outpost Packet Message Manager

2. NTS Message Maker
• and ARL Messages… 

• Select the message Type… 
Routine or Emergency

• Select the message
• Provide any additional information
• Send the message as usual
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Creating Messages
Outpost Packet Message Manager

3. On-line Report Builder
• Step 1: Set up the Report 

Settings (described previously)
• Step 2: Understand the list of 

Report <tags>

NOTE: there are some report 
variables that have to methods for 
representing them

Place a comment in the report/ comment
Prompt=

DescriptionTag

User defined text; from Report Settings<text1, 2, 3>
Tactical ID, 3 char; from Report Settings<tacid>
Tactical Location; from Report Settings<tacloc> 
Province name, 2 char; instead of state<province> 
State name, 2 char; from Report Settings<state> 
County name; from Report Settings<county> 
City name; from Report Settings<city> 
Organization; from Report Settings<org> 
Places “text” on subject line<subj>text 
BBS name; current BBS<bbs> 
Name, as entered at the Station ID form<name> 
Call, as entered at the Station ID form<C>, <call> 
Message Number; from Report Settings<M>, <msg#> 
hh:mm (22:45)<T>, <time> 
dd-mmm-yyyy (21-May-2004)<date2> 
mm/dd/yy (5/21/04). <D>, <date1> 
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Creating Messages
Outpost Packet Message Manager

3. On-line Report Builder
• Step 1: Set up the Report 

Settings (Tools > Report 
Settings)

• Step 2: Collect the list of Report 
tags, most in the format “<tag>”

• Step 3: Develop the report 
template, save as a .txt file.

NOTE: see the use of comments (/), 
<tags>, and prompts (=) 
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Creating Messages
Outpost Packet Message Manager

3. On-line Report Builder
• Step 1: Set up the Report Settings

(Tools > Report Settings)
• Step 2: Collect the list of Report 

tags, most in the format “<tag>”
• Step 3: Develop the report

template, save as a .txt file.  
• Step 4: From a new message

form, “File > Open a Report” and
choose a report template.

NOTE: Subject line is updated,
<tags> are replaced, and cursor is
positioned at the first prompt. 

• Press cntl-Tab or left-mouse to progress to the next prompt.
• Press “File > Clear Remaining Prompts” for any unfilled prompts
• Press Send when done.
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Creating Messages
Outpost Packet Message Manager

4. Copy-and-Paste from
other apps

• From Excel, highlight the 
fields to be copied, then paste 
into an Outpost message.

• At the receiving station, 
highlight and copy the 
message, then paste back 
into Excel.

• Tabs are preserved so the 
message can be pasted back 
into another spreadsheet.
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Creating Messages
Outpost Packet Message Manager

5. Import text from a file
• Open a new message
• File > Open a file
• Select the text file, press OK
• Full in the Destination and 

Subject.
• Press Send when done.
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Special Message Handling
Outpost Packet Message Manager

1. Bulletins
• To delete a bulletin off of the BBS

that you originated…
• Retrieve the bulletin from the BBS
• Open the message
• Press Expire
• On the next send/receive session, 

the bulletin will be deleted off of 
the BBS.

Notes
• You can on delete bulletins that you create
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Special Message Handling
Outpost Packet Message Manager

2. NTS Messages
• Retrieved NTS messages are not 

automatically deleted off of the BBS.  
To accept a message for servicing… 

• Retrieve the NTS message from the 
BBS

• Open the message
• Press Accept
• On the next send/receive session, 

the NTS message will be deleted off 
of the BBS.

Notes
• If you change your mind and do not plan to service the NTS message, it is 

common courtesy to post it back up on the BBS
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Special Message Handling
Outpost Packet Message Manager

3. Telpac/Winlink
• Supports internet email addressing

(format is: SMTP:name@isp.net)
• Multiple destinations
• Received message form supports

Reply-to-all for multi-destination
addressed messages

Notes
• Internet email addresses must be precede with “SMTP:”  If it is missing, the 

message will fail.
• For multiple addresses sent to non-Telpac BBS, Outpost will send the 

message to the first listed station, and then report an error.
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Special Message Handling
Outpost Packet Message Manager

4. Tactical Calls
• Definition: a call sign that identifies a 

tactical location and is operator-neutral
allowing the operators to change, without 
having the assignment name change.

• Implemented by Outpost, not the BBS
• Example: For the Santa Clara County 

Hospital System, hospitals are assigned 
Tactical Calls such as:

• 1MVECH  Mountain View El Camino Hospital
• 1PASMC  Palo Alto Stanford Medical Center
• 1SJVMC   San Jose Valley Medical Center
• 1SJGSH   San Jose Good Samaritan Hospital
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4. Tactical Calls
Notes
• Before using tactical a call, register the call 
sign with the BBS if required

Is it legal? 
• AX.25 extended address field contains 
source and destination call sign

• Outpost uses the TNC’s “my call” command 
to set the Tactical Call as the station 
identifier.

• The selected Tactical Call needs to be a 
sufficiently valid call sign to “fool” the BBS’s
call sign checking logic

• Outpost sends a “Legal Identifier String” that 
satisfies FCC Part 97.119

Special Message Handling
Outpost Packet Message Manager
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Exit the BBS,
Shut down the Interface

Initialize the Interface

Connect to the BBS

Send all messages
from Out Tray

If Private is set
• Retrieve List, Read, and 

Delete each message

If NTS is set,
• Retrieve List and Read 

each message

If Bulletins is set,
• Retrieve List, if don’t 

have it, read each 
message

Send any message
delivery, read receipts

Process Bull, NTS deletes

A Typical Session
Outpost Packet Message Manager
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A Typical Session
Outpost Packet Message Manager

• Influenced by…
• Send/Receive Settings

• Send Messages
• Only sent from the Out Tray to this BBS
• Messages must be “Sent” not “Saved”
• Moved to Sent Folder when sent

• Retrieve Messages
• Depends on the Retrieve settings; if none are 

selected, none are retrieved
• Depends on the “Keep on BBS” setting
• Bulletins are never deleted
• New messages are stored in the In Tray

• Send Receipts
• Any pending Delivery and Read Receipts are 

sent back to the requester
Exit the BBS,

Shut down the Interface

Initialize the Interface

Connect to the BBS

Send all messages
from Out Tray

If Private is set
• Retrieve List, Read, and 

Delete each message

If NTS is set,
• Retrieve List and Read 

each message

If Bulletins is set,
• Retrieve List, if don’t 

have it, read each 
message

Send any message
delivery, read receipts

Process Bull, NTS deletes
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Considerations, Limitations and Constraints
Outpost Packet Message Manager

What Outpost does not do
• No support for any bulletin board forwarding protocol
• No support for common mail protocols (POP3, SMTP, etc.)

Things to avoid
• Sending bulletins to a named person (instead of a group Identifier such as 

ALLEOC, etc.) will cause repeated retrievals by that person
• Embedding the BBS prompt string in a message (fails to ensure the 

uniqueness of the BBS prompt) will cause erroneous results
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For more information
Outpost Packet Message Manager

Visit the Outpost website…
http://www.outpostpm.org

And supporting links…
• Users Guide… http://www.outpostpm.org/#documentation
• HOW-TOs… http://www.outpostpm.org/howto.html
• Support Info… http://www.outpostpm.org/support.html
• Users group… http://groups.yahoo.com/group/outpostpacket/

Send inquiries to…
Jim Oberhofer, kn6pe@arrl.net
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Other Information
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Tools > Send/Receive Settings

UncheckedShow TNC Session Window during Send/ReceiveOther

UncheckedKeep messages on the BBS; do not delete after 
retrieving

Receiving
UncheckedPrint Message to the (default) printerReceiving
UncheckedPlay this sound on arrivalReceiving
UncheckedRetrieve Selected BulletinsRetrieving
UncheckedSkip (do not retrieve) Bulletins I sent to the BBSRetrieving
UncheckedRetrieve New BulletinsRetrieving
UncheckedRetrieve NTS MessagesRetrieving
CheckedRetrieve Private MessagesRetrieving
UncheckedSend a message immediately when it is completeAutomation

1. Default
Choose one…
1.No Automation 
2.Schedule a Send/Receive Every [     ]  minutes 
3.Schedule a Send/Receive at [   ] [   ] [   ] [   ] minutes 

past the hour

Automation
SettingSetting DescriptionArea
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Tools > Message Settings

CheckedPrompt before permanently deleting a messageDeleting 
Messages

UncheckedAlways request a read receiptTracking…

UncheckedAlways request a delivery receiptTracking 
Messages

CheckedClose original message on reply or forwardReplies 
and…

1. Default
Check one
1. Set default to Private for replies and forwards 
2. Set default to original message type (excludes NTS) 

for replies and forwards

Replies and 
Forwards

UncheckedAdd message number to subject lineSetting up…
UncheckedDefault destination [             ]Setting up…

1. Default
Choose one…
1. Set default to Private 
2. Set default to Bulletin

Setting up a 
new 
message

SettingSetting DescriptionArea
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Tools > Report Settings

BlankText Variable #3
BlankText Variable #2
BlankText Variable #1
BlankTactical ID
BlankTactical Location
BlankState/Prov
BlankCounty
BlankCity
BlankOrganization
100Next Message Number
SettingSetting Description


