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Forward
This guide provides some brief instructions on how to install, configure, set up, and use the Alt911
Call Taking System. This will step you through the basics to get you up and running.
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Overview
Introduction
Communications, in particular residential phone service, could experience an extended outage and
failure for several reasons, the most likely being:


Earthquakes



Severe weather events (tornadoes, hurricanes, etc.)



Physical or cyber‐attacks on power or communications facilities

Regardless of why or when any of these occur, there is still a need to take in requests for assistance
from the community and deliver them to the local 9‐1‐1 Dispatch Center (Public Safety Access
Point). This is where Alt911, Packet Radio, and Amateur Radio emergency responders come in.
Alt911 is an Outpost PMM add‐on program that lets the user create a 9‐1‐1 request to be sent by
AX.25 Packet Radio to the local public safety dispatch authority. Similar to what happens at a Public
Safety Access Point (9‐1‐1 call center), the request starts with a user describing a problem that
requires help from Fire, Sheriff or Police, EMS, or any Local Government services department (i.e.:
Public Works).
The questions used here are identified by Santa Clara County Communications Center as the
minimal set of information that is required to create a dispatch‐able event. Unlike handling a
telephone‐based 9‐1‐1 call, the ability to go back and forth between the caller and the dispatch
center will not occur. Therefore, getting the information right the first time is critical.
The Alt911 program essentially performs computer assisted call taking in the field and delivery
when telephone services are unavailable. It relies on…


one or more field communications teams made up of RACES, CERT, or other emergency
volunteers who interact with the public to record, format, and transmit a 9‐1‐1 request by
packet, and



a communications team at the 9‐1‐1 Dispatch Center / PSAP to receive, print, and deliver the
request for dispatch.
See the section on Deployment Scenarios for details.
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Installation
The following are the files delivered as part of the Alt911cts Installation process.

Installing Alt911
Installing the software from the Web begins by downloading the Alt911 Install Program to your PC.
1. Go to the website (TBD), navigate to the Downloads section, and look for the Alt1911
Installation program.
2. Click to download the installer. Or right click on the link, and select “Save Target As”. The
install program is named Alt911setupxxxxxx.exe, where “xxxxxx” is the current version.
The Alt911 installation program includes all the files and processes needed to install and use Alt911
on your PC. After downloading the install program, run the program as follows:
1. Click on the program to start the installation process.
2. Information. This is general information that you should check out depending on the type if
install you want to perform. When done, press Next >.
3. Select a Destination Location. This is the location where all Alt911cts programs and data files
will be installed. The default directory is: C:\MyAddons\Alt911

4.
5.

6.

NOTE: This directory is a good place to install all of your Outpost Addons. Unless you have
some other special requirements or needs, accept the default location, and press Next > to
continue.
Select Additional Tasks. If this is a stand‐alone installation, it is recommended to check the box
“ Create a Desktop Shortcut”.
Configure Outpost. Once all programs and files are installed, the installer will run Aoloader.exe
to update the Outpost Launch.local file with information on where to find the local instance of
Alt911.
a. Select YES if Alt911 is running on the same PC as Outpost PC.
b. Select NO if Alt911 is to run stand‐alone without Outpost.
Press Next > to continue.
NOTE: There must be at least one PC with both Outpost and Alt911 installed. Running Alt911
on a different PC must be on the same LAN as the Outpost PC. See the section on Deployment
Scenarios for details.
When done, double‐click on the Alt911 icon to run the program.

1. On completion, the Installer will exit.
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Basic Configuration
To verify the Installation and finish the Alt911 setup, proceed as follows:

Setting up Outpost
1. From Outpost, select Tools > Message Settings, Adv Tab.
a. Verify that the box “ Automatic start Opdirect External Message Service” is checked.
b. If it was not previously checked, CHECK this box, press OK, and restart Outpost.
2. From Outpost, set up a 911 distribution address (if not already set up).
a. Select Setup > Address Book. Press New (on the right).
b. Under Details…
i. Enter the Name: 911
ii. Enter the Org: County Comm
c. Under Packet / Email Address(es), enter:
xsc911@w1xsc, cupeoc@w1xsc
NOTE: Cupertino’s EOC address is listed here so EOC can get a copy of transmitted 9‐1‐1
requests. This is optional; use your own cities’ tactical call for your situation.
d. Notes field is optional, but recommended.
e. Verify the form looks something like this. Press OK when done.
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3. From Outpost, set the default destination address for all packet messages (can be changed on
the fly).
a. Select Tools > Message Settings.
i. Check the  Default Destination box, and enter
+911
plus sign; ‘+’ indicates this entry is a distribution list).

(must include the

ii. Press OK
4. From Outpost, verify that the Alt911 entry is in the Forms listing.
b. Select Forms. It is usually the last one on the list.

5. From Outpost, select Forms, then select Alt911.
c. Verify the Alt911cts program runs.
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Setting up Alt911cts.exe
1. Every time the Alt911cts program is run, the Alt911 Station ID form opens. Check or fill in the
fields with the information for the person
taking the reports: vv
a. Name: your first and last name
b. User ID/Call Sign: for non‐Hams,
enter in the first 6 letters of your
last name, or whatever User ID is
defined by your jurisdiction.
c. Location: The place (not address)
where you are assigned.
d. City: The City of this location.
e. Location ID: a 3 Character ID (EOC,
CTC, DZA, etc.) that is known as
this locations ID. If you do not
know it, ask your Shift Supervisor.
f. Next Event No: Usually reset to
‘1’ each day. This will be appended to a string to create the unique message ID.
g. Press OK when done.
2. If this is the first time Alt911 is ever installed, check the network configuration:
a. From Alt911, select Setup > Preferences, then the Network tab.
b. If this instance of Alt911 is running on the same PC as Outpost, set or confirm that the
Remote Host IP Address is 127.0.0.1, the Port is set as 9334, and then press Opdirect
Link Test. Confirm the test is
successful. Press OK, then File >
Exit when done.
c. If this instance of Alt911 is running
on a different PC from Outpost,
enter the IP address of the PC
running Outpost. Ask your packet
operator for this information.
Then, press Opdirect Link Test and
confirm the test is successful. Press
OK, then File > Exit when done.
d. If a problem occurs, refer to the
Troubleshooting section.
Alt911cts set up is complete.
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Creating 9‐1‐1 Requests
This section describes how to use the Alt911 program.

Main Form
The Main form contains the following:
1. Displays the listing of 9‐1‐1 requests and their various states. Clicking on the column
headers will sort that respective column.
2. New Report button: opens the Call Taking data entry form.
3. View List buttons. Shows specific messages based on their state.
4. Various Menu options.

The four message states are:
1. Draft – message was started and SAVED. It was not submitted.
2. Ready – message is complete, but was not Submitted
3. Submitted – message was completed and submitted to Outpost for transmission
4. Deleted – the message was selected for deletion
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Data Collection Form
On pressing new, the following form is opened.

Each request includes information on a specific problem requiring a specific public safety responder
(Fire, Law, EMS, Local Govt). Highlighted are required.
The form is divided into 3 areas:
1. Incident Summary and Reporting Person (RP).

What are you reporting

Public Safety Responder
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In a few words, briefly enter a problem (Details come
later)
Example:
House Fire
Car Accident
Difficulty breathing
Tree down
Click on one of the four buttons to select the
appropriate public safety responder(s). This will enable
the appropriate tab for further data collection.
9

Location of the problem

Location L/U Button

Reporting Person (RP)

RP L/U Button

Three fields that describe where the event is taking
place. These fields are:
1. Location, Address: Required
2. City: Required
3. Other Location Details: Optional Field. Example”
cross Street
building name
“in the back”
Last Used. This button will load the last address
entered. It is useful if the person with the problem is
describing the same location.
Three fields that include information about this RP.
These fields are
1. Name: Required.
2. Address: Optional. Enter the address and street
in this field.
3. Phone: Optional. However, this is required for
LAW calls if the RP wants to be contacted.
Last Used. This button will load the last RP entered.

2. General Details

Last Seen:

Details:

Required. When was the incident last observed? Since
the RP ran or drove to get to you, this gives dispatch a
sense of the duration of the event occurring. This
fieldcan be set either in absolute time (hh:mm) or
relative time (‐min). When relative time is entered,
Alt911 will calculate the time for you.
Example:
13:04
4:35 PM
‐15
(15 minutes ago)
‐60
(1 hour ago)
Required. enter all other supporting details. Include
things such as extent of the fire, observed smoke,
flames, from where; details on a criminal activity, state
of a person in medical distress, details on downed trees
or power poles, etc.

3. Specific Details.
Each responder type has its own set of additional questions that need to be answered.
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i.

MEDICAL

Age:

ii.

Gender:

Required. Age or approximate age of the person with
the medical problem.
Example:
35
late 60s
Required.

Conscious?

Required. Is this person conscious? Select No or Yes

Breathing?

Required. Is this person breathing? Select No or Yes

FIRE

People in side?

iii.

Required.
Example:

Yes
no details

LAW

If you are reporting a crime being committed by one or more individuals, then All
of these fields are REQUIRED. If the person reporting doesn’t know, state that.
Description of
person.
January 30, 2021

Include any known observations on the perpetrators.
Include: any distinguishing marks or clothing.
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Weapon Involved?

Direction of Travel:
Vehicle Description:

This is important. Your police or sheriff need to know
to what they are responding.
Example:
No
Knife, about 5”
Gun, no description
Unknown
Any details on which way the perpetrator may be
headed. N/A if not necessary for this report.
License Plate, and State are in the event a vehicle is
involved. List all details of known.

NOTE: By taking this report, you may become part of the Chain of Evidence in the event
any future legal and court action is taken. Check with your local dispatch center
or jurisdiction for the rules and guidance in this area.
iv.

LOCAL GOV

1. No additional information is needed. Put all details in the Details
section.

NOTE:

One or more responder options can be selected at the same time. For
instance: a two‐car accident with injuries (MED) and gas spill (FIRE). Select MED, FIRE.

Form Controls are:
1. Submit.
i. Verifies that all required fields are filled in; highlights any required field that is
missing content in yellow.
ii. Alt911 performs a network connect with Opdirect and passes the message to that
program.
iii. Opdirect then writes the message to the Outpost DB.
iv.
Outpost automatically opens this message to be completed by the packet
operator and then transmitted (Send/Receive).
2. Save: May be partially filled in and you need to take a walk‐up for a higher priority
request.
3. Delete: delete this message. Essentially, we started it and now will abandon it.
4. Close. Close this form, return to the main display.
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Data Collection Process
In general, 9‐1‐1 call taking is essentially asking the right questions and collect enough information
for the 9‐1‐1 Dispatch Center to create a dispatch‐able call. This section will not teach you how to
manage the questions, but gives you the sense of what you need to do. Check with your jurisdiction
call center for details and pointers.
Essentially, the ALT911 steps are:
1. Call Taker press New Request.
2. Ask: What are you reporting?
3. Based on their answer, determine which Public Safety responder organization is needed and
press the respective button.
4. Ask: The location of the problem. Make sure you get the City.
5. Ask: Name, address, phone number of the person giving you this report.
6. Ask: How long ago did you see this problem?
7. Ask: Any other details: “what did you see?” “what is happening now?” etc.
8. Ask: Specific Public Safety responder questions.
9. Press Submit.
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Deployment Scenarios
There are two field deployment scenarios that you may want to consider:

Single PC Setup
One instance of Alt911cts is running on the same PC with Outpost. In this case, the 9‐1‐1 request
taker is also the field packet operator.

1. Resident comes up with a request for help.
2. On ALT911, Call Taker press New Request,
asks all the questions, then presses Submit.
3. Alt911cts makes a network call to
Opdirect.exe (IP Address of this PC is
127.0.0.1) and passes the message.
4. Opdirect.exe receives the message,
identifies it as an !ALT911! message, and
writes it to the Outpost message DB.
5. Outpost detects a new message and opens
the message.
6. The packet operator enters the destination,
confirms all other message header fields,
and presses SEND.
7. The message is transmitted to the BBS.
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8. Because Outpost is automatically polling the BBS
for messages addressed to XSC911, it retrieves
the message from the BBS.
9. Outpost detects it is an !ALT911! message and
passes it to Alt911rpt.exe where it is printed.
10. Operator then delivers the message for dispatch.
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Multiple PC Setup
More than instance of Alt911cts are deployed on different PCs or Windows Tablets. They are all
connected to a local router (either wired or wireless) along with the Outpost PC. The 9‐1‐1 request
takers are dedicated to only taking requests. The packet operator only manages the packet station.

1. Resident comes up to one of the Call Takers
with a request for help.
2. That Call Taker press New Request., asks all
the questions, presses Submit.
3. Alt911cts creates the message and passes it.
4. Each Alt911cts program was configured to use
the IP Address of the Outpost PC (for instance:
192.168.0.104). It makes a network call to
Opdirect.exe and passes the message.
5. Opdirect.exe receives the message, identifies
it as an !ALT911! message, and writes it to the
Outpost message DB.
6. Outpost detects a new message and displays
the message.
7. The packet operator determines the
destination, confirms all other fields, and
presses SEND.
8. The message is transmitted to the BBS.
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BBS, it retrieves the message from the BBS.
10. Outpost detects it is an !ALT911! message and
passes it to Alt911rpt.exe where it is printed.
11. Operator then delivers the message for dispatch.

15

Troubleshooting
Alt911cts.exe Error Messages
Cannot connect to Opdirect.

1. Verify that:
a. Outpost and Opdirect EMS are running,
b. Alt911cts network setting is pointing to the Outpost PC.

Alt911rpt.exe Error Messages
Link Test Fails

Msg send to Opdirect failed

1. Verify that Opdirect.exe is running on the Outpost PC.
2. Verify that the IP Address configured in Alt911cts.exe is set to the
IP address of the PC where Outpost and Opdirect.exe are running.
3. Verify that networking is functional.
4. Check the following
a. Confirm the Host Name and Port Number match Opdirect
b. Confirm that Opdirect is running
1. Check that there is a configured printer available.
2. Installation error… contact the Add‐on developer with the details.

No Printer Installed
Could not build Forms
Definition Array; Forms file not
found
Could not build Data Definition 3. Contact the Add‐on developer with the details.
Array; Data file not found

Programs
Alt911cts.exe

Main 9‐1‐1 request data collection program; presents the user with a
message‐based data environment to manage new, saved, and sent 9‐1‐1
requests.
This program can reside either on the same PC as Outpost or on a different PC
on the same LAN as Outpost. See the section on Deployment Scenarios for
details.

Alt911rpt.exe

9‐1‐1 Request printing program; is called by Outpost to print an incoming
request. Different command options allow the user to configure the program
to execute the printing task.
This program resides on the same PC as Outpost.

Aoloader.exe

Installation helper program; is called as part of the Alt911 installation and
prompts the user whether to complete the installation as either a stand‐alone
installation (installed on a PC that does not have Outpost) or to be integrated
with Outpost (installed on the same PC as Outpost).
When run, the program reads the Alt911.local file, extracts the Addon
Program ID, and checks if this ID is found in Outpost’s Launch.local file.
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Config Files
Alt911.ini

Alt911 Configuration File. Contains the declarations for how Outpost will call
the Alt911 addon. This file is loaded each time Outpost is run. In you change
how you want Alt911 to execute, change the declarations here and then
restart Outpost.

Alt911.local

Alt911 Launch.Local input file. At installation time, this file is read by
Aoloader.exe and is loaded into the Outpost Launch.local file. The content of
this file is usually an INCLUDE statement that points to where the
Alt911.launch file resides.

Alt911.launch

Alt911 Launch file. This file is loaded when Outpost is run for the purpose of
populating the Forms menu. This file is usually referenced by the INCLUDE
statement loaded into Outpost’s Launch.local file.

Alt911‐Form‐Def.csv

Alt911 Report form definition file. Contains the geometries and text that
define the Alt911 Output Report. This file is one of the command‐line
parameters when calling Alt911rpt.exe.
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